× Spørsmål rundt sikkerhet og eventuelle sikkerhetsproblemer ("hacking" eller mistanke om dette).

PhpMailer4 vs phpMailer5

PhpMailer4 vs phpMailer5 opprettet av Grethe C Nordheim

Litt oppgitt nå, men håper på litt råd ;)

Jeg har fått beskjeden her:
PHPMailer-PHP4 1.73 - VULNERABLE: ./www/includes/classes/class.phpmailer.php
PHPMailer-PHP4 1.02 - VULNERABLE: ./www/includes/classes/class.smtp.php

Okey, det er greit nok, jeg skjønner meldinga. Men jeg skal oppgradere fra 1.5.0 til 1.5.1 og såvidt jeg kan se i change-log så er ikke disse filene endret. Dermed vil jo problemet bestå.

Så da kommer mitt store spørsmål, kan jeg klare å bytte det her slik at jeg får versjon PHP 5/6? Er det i det hele tatt mulig å gjøre dette?
Jeg kommer sikkert til å miste enda mer hår/farge underveis, men hvis det er mulig så trur jeg nesten det kan være verdt det.
Jeg fant noe som ser ut til å være en grei forklaring her:
opencart.web2y.net/8000-internal-server-error
men et lite råd i en eller annen retning ville vært flott
09/11/2012 23:22 #5518

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Torje Rørvik i emne PhpMailer4 vs phpMailer5

Ser at jeg også har fått den advarselen, men kan ikke gi deg noe svar på spørsmålet.

Det er jo litt rart at 1.5.x fortsatt har gamle basis moduler med PHP4.

Fant et relativt gammelt (og betryggende?) innlegg på zen-cart.com som omhandler nettopp advarselen fra Domeneshop:
Følgende bruker(e) sa Takk: Grethe C Nordheim
13/11/2012 09:38 #5519

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Rune Rasmussen i emne PhpMailer4 vs phpMailer5

Domeneshop har det med å rope 'ulv ulv' dessverre, og det mest usikre der er vel gjerne konfigurasjon og drift av serverne - da nær sagt alt hackes mer der enn andre (mer seriøse?) steder ...

Uansett er smtp ofte mer stabilt og pålitelig, og kan med fordel brukes fremfor PHPMail, SendMail el.a.
13/11/2012 12:16 #5520

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Grethe C Nordheim i emne PhpMailer4 vs phpMailer5

Rune har nok rett her, de roper ulv litt ofte kan hende ;)
Men jeg har brukt domeneshop i så mange år at det er uaktuelt for meg å bytte.
For øvrig har jeg nå fått beskjed om at de godtar phpmailer4 inn til videre, så lenge resten av zen-cart installasjonen er oppdatert.

Jeg får vurdere litt frem og tilbake hvordan jeg løser dette, finner jeg på noe lurt, som passerer sikkerhetskontrollen til domeneshop så poster jeg det her ;)

Tusen takk for svar begge to
13/11/2012 19:10 #5521

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

arastta logo horizontal 326x58

opencart logo 298x58

vm logo 220x58

woocommerce logo 286x58

zen cart logo 217x58