Oppgradering av PHP

Oppgradering av PHP opprettet av Espen Braathen

Noen her inne, som kan fortelle hvordan man oppgaraderer ZEN Cart, slik at den virker med PHP 7.2?
30/01/2019 18:00 #5737

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Rune Rasmussen i emne Oppgradering av PHP

Hei Espen, du sier ikke noe om hvilken versjon av Zen Cart du har, men det er jo uansett den generelle fremgangsmåten som gjelder, som det finnes både norsk og engelsk beskrivelse av. Du må vel opp på Zen Cart 1.5.6 for PHP 7.2/7.3-støtte, men har du 1.5.5 kan du fint bruke PHP 7.1 ut året.

En versjon på norsk finnes her: www.zen-cart.no/dokumentasjon/norsk/21-3...a-oppdatere-zen-cart

Den offisielle engelske finnes her: www.zen-cart.com/content.php?148

Dersom noe er uklart i forhold til disse får du gjerne spørre litt mer spesifisert, men ser det helt gresk ut bør du kanskje vurdere å få noen til å hjelpe deg med selve jobben heller.
30/01/2019 18:19 #5738

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Espen Braathen i emne Oppgradering av PHP

Hei

Tror det er versjon 1.5.0 eller noe. Den som støttet forrige utgave av PHP før den ble 7 i allefall.
Kort fortalt så bruker jeg domeneshop som host, og de oppgraderte til PHP 7.2 og da slutta siden å virke.
30/01/2019 19:03 #5739

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Rune Rasmussen i emne Oppgradering av PHP

Dersom ikke Domeneshop lar deg bruke noe annet enn PHP 7.2 bør du asap finne deg et nytt netthotell, hvor du selv får velge PHP-versjon. Men sjekk ut denne i alle fall: domene.shop/faq?id=362#toc_12

Utover det står forrige svar i forhold til hva du må gjøre dersom du skal oppdatere Zen Cart, noe du jo uansett er anbefalt å gjøre veldig mye oftere enn det du har gjort til nå. Du utsetter nå deg selv og dine kunder for sikkerhetshull og potensielt missbruk av persondata, og sliter da også i forhold til den nye personvernforordningen (GDPR).
30/01/2019 19:16 #5740

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Espen Braathen i emne Oppgradering av PHP

Helt gresk for meg. Er dette noe du kan fikse, mot betaling selvfølgelig?
30/01/2019 19:42 #5741

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

Besvart av Rune Rasmussen i emne Oppgradering av PHP

Dersom man ønsker å hyre noen for en jobb kan man poste i forumet ' Kommersiell hjelp ønskes '

Eventuelt ta kontakt med en konsulent eller et firma via deres offisielle kanaler, ref. kontaktinformasjon på deres nettsider.
30/01/2019 22:37 #5742

Vennligst Logg inn eller Registrer konto for å bli med i samtalen.

arastta logo horizontal 326x58

opencart logo 298x58

vm logo 220x58

woocommerce logo 286x58

zen cart logo 217x58